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Every conceivable measure has been taken to ensure the correctness and com-
pleteness of this documentation. However, as errors can never be fully ex-
cluded we would appreciate any information or ideas at any time. 

We wish to point out that the software and hardware terms as well as the 
trademarks of companies used and/or mentioned in the present manual are 
generally trademark or patent protected. 
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1 Important comments 
To ensure fast installation and start-up of the units described in this manual, 
we strongly recommend that the following information and explanation is 
carefully read and adhered to. 

1.1 Legal principles 

1.1.1 Copyright 

This manual is copyrighted, together with all figures and illustrations con-
tained therein. Any use of this manual which infringes the copyright provi-
sions stipulated herein, is not permitted. Reproduction, translation and elec-
tronic and photo-technical archiving and amendments require the written con-
sent of WAGO Kontakttechnik GmbH & Co. KG. Non-observance will entail 
the right of claims for damages. 

1.1.2 Personnel qualification 

The use of the product detailed in this manual is exclusively geared to special-
ists having qualifications in PLC programming, electrical specialists or per-
sons instructed by electrical specialists who are also familiar with the valid 
standards. WAGO Kontakttechnik GmbH & Co. KG declines all liability re-
sulting from improper action and damage to WAGO products and third party 
products due to non-observance of the information contained in this manual. 

1.1.3 Intended use 

For each individual application, the components supplied are to work with a 
dedicated hardware and software configuration. Modifications are only admit-
ted within the framework of the possibilities documented in the manuals. All 
other changes to the hardware and/or software and the non-conforming use of 
the components entail the exclusion of liability on part of WAGO Kon-
takttechnik GmbH & Co. KG. 

Please direct any requirements pertaining to a modified and/or new hardware 
or software configuration directly to WAGO Kontakttechnik GmbH & Co. 
KG. 
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1.2 Range of validity 
This application note is based on the stated hardware and software of the spe-
cific manufacturer as well as the correspondent documentation. This applica-
tion note is therefore only valid for the described installation. 

New hardware and software versions may need to be handled differently. 
Please note the detailed description in the specific manuals. 

1.3 Symbols 

  
Danger 
Always observe this information to protect persons from injury. 

  
Warning 
Always observe this information to prevent damage to the device. 

  
Attention 
Marginal conditions must always be observed to ensure smooth operation. 

  

ESD (Electrostatic Discharge) 
Warning of damage to the components by electrostatic discharge. Observe 
the precautionary measure for handling components at risk. 

  

Note 
Routines or advice for efficient use of the device and software optimization. 

  

More information 
References to additional literature, manuals, data sheets and INTERNET 
pages 
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2 Description 
The purpose of this application note is to provide a step-by-step example of 
interfacing a Siemens S7 PLC with PROFINET Scanner to the WAGO 750-
340 PROFINET Coupler.   

3 Reference Material 
This procedure has been tested with, but is not limited to, the following hard-
ware and software: 

Siemens CPU315F-2 PN/DP Processor/PROFINET Scanner 

Siemens SIMATIC Manager STEP 7 Software, Version V5.3 + SP3, Rev K5.3.3.0 

gsdml-v2.0-wago-series750_753-20070115.xml (PROFINET GSD File) 

WAGO 758-500 5-Port Ethernet Switch 

WAGO PROFINET Node consisting of: 

WAGO 750-340 PROFINET Coupler 
750-402 4Ch 24VDC Digital Input Module (4 Bits Digital Inputs) 
750-504 4Ch 24VDC Digital Output Module (4 Bits Digital Outputs) 
750-467 2Ch 0-10VDC Analog Input Module (2 Words Analog Inputs) 
750-550 2Ch 0-10VDC Analog Output Module (2 Words Analog Outputs) 
750-600 End Module 
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4 Solution 
This document assumes that you have an overall understanding of the Siemens 
S7 hardware and software.  It focuses on the basics of configuring the WAGO 
750-340 PROFINET Coupler in the STEP 7 HW-Configuration tool.  After the 
hardware configuration is complete, the WAGO 750-340 is available for use as dis-
tributed I/O in a STEP 7 project.  

This procedure is divided into the following steps: 

• Configure the S7 PLC in the STEP 7 HW-Configuration  

• Install the WAGO 750-340 GSD file  

• Configure the WAGO 750-340 in the STEP 7 HW-Configuration 

• Assign a Device Name to the WAGO 750-340 in the STEP 7 HW-
Configuration 

• Download the hardware configuration to the S7 PLC 

• Test the WAGO 750-340 in the ONLINE mode of the STEP 7 HW-
Configuration 
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4.1 Configure the S7 PLC in the STEP 7 HW-Configuration 
In this section the Siemens CPU315F-2 PN/DP Processor/PROFINET Scanner is 
added to the STEP 7 HW-Configuration.  The PROFINET scanner is assigned 
an IP address and a PROFINET subnet is created. 

Launch SIMATIC Manager and create a new project. 
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In the New Project dialog box enter the name of the project. 

Example: S7_PN_AppNote  

 

Click OK.  The project name appears in the project organizer. 
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Right-click on the project name and select Insert New Object > SIMATIC 
300 Station from the menu list as shown below.  

 

 

The project organizer is displayed. 
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Right-click on SIMATIC 300(1) and select Open Object.  

 

 

The HW Config window appears.  Select the menu command Insert > Insert 
Object... 

 

 

From the list select SIMATIC 300 > RACK-300 > Rail. 
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An empty station grid is displayed.  The components of the local PLC rack 
need to be added to the grid, which in this case includes a power supply and 
the CPU. 

 

Right-click on Slot 1 and select Insert Object.... Then select the power supply 
for your system. 

 

Right-click on Slot 2 and select Insert Object�. Then select the model and 
version of the CPU. 
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A Properties dialog box is displayed for defining the Ethernet interface.  Enter 
the IP address and Subnet mask of the PROFINET Scanner.  When this is 
complete, click New.... 

 

Another Properties dialog box is displayed for defining a new subnet.  Enter a 
name for the PROFINET network, such as ProfiNet1 and click OK.  Click 
OK a second time to exit the Properties window. 
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The S7 PLC and PROFINET scanner are now configured in the STEP 7 HW-
Configuration.  The SIMATIC Manager will display a network similar to the 
one shown below: 
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4.2 Install the WAGO 750-340 GSD File 
A GSD file (Generic Station Description), which is supplied by the device 
manufacturer, contains a description of the PROFINET device. A GSD file 
provides a simple way to import a device�s profile into a PROFINET 
configuration tool, like the STEP 7 HW-Configuration tool. 

The current revision of the WAGO 750-340 GSD file is named �gsdml-v2.0-
wago-series750(753)-20060703.xml�.  This file can be obtained from the 
download area of the WAGO website (www.wago.com) or by contacting 
WAGO Technical Support.   

To stall the WAGO 750-340 GSD file in STEP 7 HW-Configuration, select 
the menu command Options > Install GSD file�. 

 

 

http://www.wago.com/
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The following dialog box appears.  Click Browse� and navigate to the folder 
where the WAGO 750-340 GSD file is stored.  Select the GSD file in the list 
box and click Install.  

 

 

After successfully installing the WAGO 750-340 GSD file, its profile is 
available for the STEP 7 HW-Configuration tool.  
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4.3 Configure the WAGO 750-340 in the STEP 7 HW-
Configuration 

In this section, the WAGO 750-340 PROFINET Coupler is added to the STEP 
7 HW-Configuration.  WAGO I/O modules are then added to the configura-
tion in the order in which they are physically located in the node.  

Click on the PROFINET network.  

 

Then right-click on it to bring up the menu shown below.  Select the menu 
command Insert Object� 
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From the menu, select Additional Field Device.  A list of installed devices is 
displayed.  Select the 750-340 V01.00.xx.   

 

The WAGO 750-340 is added to the network as shown below. 

 

Right-click on the WAGO node and select Object Properties�.  
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A Properties dialog box is displayed.  The default Device Name and Device 
Number are displayed for the WAGO 750-340.  The STEP 7 HW-
Configuration automatically generates these values from the device profile.  
These values can be change if desired.  Click OK to continue.   

 

 

 

  

Note: All devices on an Ethernet subnet must have a unique Device Name.  
The Device Names must also satisfy DNS naming conventions. 

 

  

Note: The STEP 7 HW-Configuration automatically assigns an IP address to 
the WAGO 750-340.  Starting with the IP address of the IO controller, STEP 
7 HW-Configuration searches for the next available IP address. 
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Next the STEP 7 HW-Configuration tool is used to assign the I/O modules in 
the WAGO 750-340 PROFINET node.  All modules are entered in the order in 
which they are physically located in the node. 

Click on the WAGO node.   

  

The I/O grid for the WAGO 750-340 is displayed at the bottom of the screen.  
Right-click on slot 1 and select Insert Object... 
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Select the 750-340� > Digital Input Module > 75x-402 4DI(+4 BIT 1) 

 

  

Note:  There are two parts that start with the 75x-402 part number.  The 75x-
402 4DI (+4Bit 0) is used when 75x-402 module starts a new byte in the in-
put process image.  This module only uses the first 4 bits of the byte.  If a 
second 75x-402 module is needed, the 75x-402* 4DI (-4Bit 0) part is used.  
This part serves as a placeholder and fills-in the last 4 bits of the existing 
byte. 

 

Right-click on slot 2 and select Insert Object...  Then select the 750-340� > 
Digital Output Module > 75x-504 4DO(+4 Bit 0). 

Right-click on slot 3 and select Insert Object...  Then select the 750-340� > 
Analog Input Module > 75x-467 2AI, 0-10V. 

Right-click on slot 4 and select Insert Object...  Then select the 750-340� > 
Analog Output Module > 75x-550 2AO, 0-10V. 
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When all the I/O modules are added, the grid should appear as below: 

 

The addresses of the I/O modules are automatically assigned and displayed in 
the grid.  These addresses can now be use in the S7 project. 

Input Process Image Map 

Input Device IEC-61131 Address 
750-402 Channel 1 I 0.0 
750-402 Channel 2 I 0.1 
750-402 Channel 3 I 0.2 
750-402 Channel 4 I 0.3 
750-467 Channel 1 IW 256 
750-467 Channel 1 IW 258 

 

Output Process Image Map 

Output Device IEC-61131 Address 
750-504 Channel 1 Q 0.0 
750-504 Channel 2 Q 0.1 
750-504 Channel 3 Q 0.2 
750-504 Channel 4 Q 0.3 
750-550 Channel 1 QW 256 
750-550 Channel 1 QW 258 

 

  

Note: Only the modules that produce or consume data should be added to the 
I/O grid.  Some modules, such as the 750-600 end module and some power 
feed modules, do not send or receive data.  Modules such as these should not 
be included in the I/O grid. 
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4.4 Assign a Device Name to the WAGO 750-340 
The Assign device name dialog box is used to assign a Device Name to a re-
mote I/O device.  This dialog box displays all devices available on the 
Ethernet subnet along with their IP address (if available) and their MAC ad-
dress, as well as the device type determined online. 

In the STEP 7 HW-Configuration select the WAGO 750-340 node by clicking 
on it. 

 

Then select PLC >Ethernet > Assign Device Name� from the menu. 
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The device name for the selected WAGO 750-340 node is displayed in the 
Device name list box (in the example below the device name is also called 
�WAGO 750-340�).  To assign this configuration to a physical device, select 
the physical device from the Available devices list, and click the Assign Name 
button. 

 

Click Close when complete. 
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4.5 Download the hardware configuration to the S7 PLC 
In this section the STEP 7 HW-Configuration tool is used to download the off-
line configuration to the S7 PLC. 

In the STEP 7 HW-Configuration window, select the menu command PLC > 
Download�. 

 

The Select Target Module dialog box is displayed. 

 

Select the device type from the Target modules list and click OK.  
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The Select Node Address dialog box is displayed. 

 

Changes can be made to the target station if required.  Click OK to continue.   

A Download dialog box is displayed showing the progress of the download.   

 

When the download is complete, the dialog box disappears. 
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4.6 Testing the WAGO 750-340 in the ONLINE Mode 
The STEP 7 HW-Configuration can be used in ONLINE mode to test the IO 
configuration. 

To start ONLINE mode, select the menu command Open ONLINE. 

 

Select WAGO 750-340 node by clicking on it. 

 

Then right-click on module you want to monitor or control.  For this example, 
right-click on slot 1, the WAGO 750-402, and select Monitor/Modify 

 



28 � Solution 

  Application note 
  A115400 

The Monitor/Modify�dialog box displays the inputs of the 750-402 module in 
table format.  Click on the Status Value button to refresh the screen. 

 

The digital input and output modules are displayed in binary format and ana-
log modules are in word format. 
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