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1 Notes about this Documentation 
Pos: 8 /Alle Serien (Allgemeine M odul e)/Sicher heits- und sonstige Hinweise/Hinweis/Hi nweis : D okumentation aufbewahr en @ 4\mod_1237987339812_21.docx @ 29026 @  @ 1 
 

 

 

 
Always retain this documentation! 
This documentation is part of the product. Therefore, retain the documentation 
during the entire service life of the product. Pass on the documentation to any 
subsequent user. In addition, ensure that any supplement to this documentation is 
included, if necessary. 

 Pos: 9 /Seri e 759 ( WAGO- Software)/Hi nweise zur D okumentati on/Gültigkeitsbereich ETSx- Plug-in (KNX)  (759- 318) @ 19\mod_1403704692068_21.docx @ 156588 @ 2 @ 1 
 

1.1 Scope 
This documentation applies for the WAGO ETS Plug-in in conjunction with ETS 
and the KNX IP controller 750-889.  

Pos: 10.1 /All e Seri en ( Allgemei ne Module)/Ü berschriften/Ebene 2/Ur heberschutz - Ü berschrift  2 @ 23\mod_1435647042188_21.docx @ 184808 @ 2 @ 1 
 

1.2 Copyright 
Pos: 10.2 /All e Seri en ( Allgemei ne Module)/R echtliches , Allgemei nes /Urheberschutz ausführlich @ 4\mod_1235565145234_21.docx @ 27691 @  @ 1 
 

This Manual, including all figures and illustrations, is copyright-protected. Any 
further use of this Manual by third parties that violate pertinent copyright 
provisions is prohibited. Reproduction, translation, electronic and phototechnical 
filing/archiving (e.g., photocopying) as well as any amendments require the 
written consent of WAGO Kontakttechnik GmbH & Co. KG, Minden, Germany. 
Non-observance will involve the right to assert damage claims. 

Pos: 10.3 /Dokumentation allgemei n/Glieder ungselemente/---Seitenwechsel--- @ 3\mod_1221108045078_0.docx @ 21810 @  @ 1 
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1.3 Symbols 
Pos: 10.5.1 /All e Serien ( Allgemei ne Module)/Sicherheits- und sons tige Hi nweise/Gefahr/Gefahr: _War nung vor Personenschäden allgemei n_ - Erläuter ung @ 13\mod_1343309450020_21.docx @ 101029 @  @ 1 
 

 
  

Personal Injury! 
Indicates a high-risk, imminently hazardous situation which, if not avoided, will 
result in death or serious injury. 

 Pos: 10.5.2 /All e Serien ( Allgemei ne Module)/Sicherheits- und sons tige Hi nweise/Gefahr/Gefahr: _War nung vor Personenschäden durch el ektrischen Strom_ - Erläuterung @ 13\mod_1343309694914_21.docx @ 101030 @  @ 1 
 

 

 

 
Personal Injury Caused by Electric Current! 
Indicates a high-risk, imminently hazardous situation which, if not avoided, will 
result in death or serious injury. 
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Personal Injury! 
Indicates a moderate-risk, potentially hazardous situation which, if not avoided, 
could result in death or serious injury. 

 Pos: 10.5.4 /All e Serien ( Allgemei ne Module)/Sicherheits- und sons tige Hi nweise/Vorsicht/Vorsicht: _War nung vor Personenschäden allgemein_ - Erläuterung @ 13\mod_1343310028762_21.docx @ 101038 @  @ 1 
 

 
  

Personal Injury! 
Indicates a low-risk, potentially hazardous situation which, if not avoided, may 
result in minor or moderate injury. 
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Damage to Property! 
Indicates a potentially hazardous situation which, if not avoided, may result in 
damage to property. 
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Damage to Property Caused by Electrostatic Discharge (ESD)! 
Indicates a potentially hazardous situation which, if not avoided, may result in 
damage to property. 

 Pos: 10.5.7 /All e Serien ( Allgemei ne Module)/Sicherheits- und sons tige Hi nweise/Hi nweis /Hinweis: _Wichtiger Hi nweis  allgemein_ - Erläuterung @ 13\mod_1343310326906_21.docx @ 101047 @  @ 1 
 

 

 

 
Important Note! 
Indicates a potential malfunction which, if not avoided, however, will not result in 
damage to property. 

 Pos: 10.5.8 /All e Serien ( Allgemei ne Module)/Sicherheits- und sons tige Hi nweise/Infor mation/Infor mation: _Weiter e Infor mation allgemei n_ - Erl äuter ung @ 13\mod_1343310439814_21.docx @ 101051 @  @ 1 
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Additional Information: 
Refers to additional information which is not an integral part of this 
documentation (e.g., the Internet). 
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1.4 Number Notation 
Pos: 10.8 /All e Seri en ( Allgemei ne Module)/R echtliches , Allgemei nes /Zahlensysteme @ 3\mod_1221059454015_21.docx @ 21711 @  @ 1 
 

Table 1: Number Notation 
Number Code Example Note 
Decimal 100 Normal notation 
Hexadecimal 0x64 C notation 
Binary '100' 

'0110.0100' 
In quotation marks, nibble separated with 
dots (.) 

 
Pos: 10.9 /All e Seri en ( Allgemei ne Module)/Ü berschriften/Ebene 2/Schriftkonventi onen - Ü berschrift  2 @ 23\mod_1435647186005_21.docx @ 184814 @ 2 @ 1 
 

1.5 Font Conventions 
Pos: 10.10 /Alle Serien (Allgemeine M odul e)/Rechtliches, Allgemeines/Schriftkonventi onen @ 3\mod_1221059521437_21.docx @ 21714 @  @ 1 
 

Table 2: Font Conventions 
Font Type Indicates 
italic Names of paths and data files are marked in italic-type.  

e.g.: C:\Program Files\WAGO Software 
Menu Menu items are marked in bold letters.  

e.g.: Save 
> A greater-than sign between two names means the selection of a 

menu item from a menu.  
e.g.: File > New 

Input Designation of input or optional fields are marked in bold letters,  
e.g.: Start of measurement range 

“Value” Input or selective values are marked in inverted commas.  
e.g.: Enter the value “4 mA” under Start of measurement range. 

[Button] Pushbuttons in dialog boxes are marked with bold letters in square 
brackets.  
e.g.: [Input] 

[Key] Keys are marked with bold letters in square brackets.  
e.g.: [F5] 

 
Pos: 11 /D okumentation allgemei n/Glieder ungselemente/---Seitenwechsel--- @ 3\mod_1221108045078_0.docx @ 21810 @  @ 1 
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2 Important Notes 
Pos: 12.2 /Serie 759 (WAGO-Softwar e)/Hinweise zur Dokumentation/Wichtige Erläuterungen/Wichtige Erläuterungen - Einl eitung Software @ 12\mod_1333628906785_21.docx @ 93367 @  @ 1 
 

This section describes the legal principles and system requirements for using the 
software in compliance with intended purpose, underlying provisions and stated 
specifications.  

Pos: 12.3 /All e Seri en ( Allgemei ne Module)/Ü berschriften/Ebene 2/R echtliche Gr undlag en - Überschrift 2 @ 3\mod_1221060626343_21.docx @ 21726 @ 2 @ 1  

2.1 Legal Bases 
Pos: 12.4 /All e Seri en ( Allgemei ne Module)/R echtliches , Allgemei nes /Änder ungsvorbehalt  - Überschrift 3 und Inhalt @ 3\mod_1221060036484_21.docx @ 21720 @ 3 @ 1  

2.1.1 Subject to Changes 

WAGO Kontakttechnik GmbH & Co. KG reserves the right to provide for any 
alterations or modifications that serve to increase the efficiency of technical 
progress. WAGO Kontakttechnik GmbH & Co. KG owns all rights arising from 
the granting of patents or from the legal protection of utility patents. Third-party 
products are always mentioned without any reference to patent rights. Thus, the 
existence of such rights cannot be excluded. 

Pos: 12.5 /Serie 759 (WAGO-Softwar e)/Hinweise zur Dokumentation/Wichtige Erläuterungen/Personalqualifi kation Software @ 12\mod_1331792915159_21.docx @ 91000 @ 3 @ 1 
 

2.1.2 Personnel Qualification 

Any steps related to the use of WAGO software may only be performed by 
qualified employees with sufficient knowledge of handling the respective PC 
system used. 

Steps in which files are created or changed on the PC system may only be 
performed by qualified employees with sufficient knowledge in the administration 
of the PC system used in addition to the aforementioned. 

Steps in which the behavior of the PC system in a network is changed may only 
be performed by qualified employees with sufficient knowledge in the 
administration of the network used in addition to the aforementioned. 

Pos: 12.6 /Dokumentation allgemei n/Glieder ungselemente/---Seitenwechsel--- @ 3\mod_1221108045078_0.docx @ 21810 @  @ 1 
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2.2 System Requirements 
Pos: 12.8 /Serie 759 (WAGO-Softwar e)/Hinweise zur Dokumentation/Wichtige Erläuterungen/Systemvoraussetzung en ETSx-Pl ug-in (759-318)  @ 25\mod_1457690425124_21.docx @ 204038 @  @ 1 
 

Table 3: ETS System Requirement  

CPU Min. 2 GHz processor capacity 
Operating System Windows Vista (SP2), Windows 7 (SP1), Windows 8, 

Windows 8.1, Windows 10 
Main memory 
(RAM) 

 
Min. 2 GB, 4 GB recommended 

Fixed disk storage 
(HDD) 

 
Min. 20 GB 

Monitor Super VGA or higher 
Resolution  1024 × 768 
Mouse Recommended 
Interface USB, KNXnet/IP controller 750-889 as router, KNXnet/IP 
Others The ETS Plug-in requires the ETS in version 4.0 or higher 
 

 

 

 
Importing e!COCKPIT .xml Files 
When using e!COCKPIT, the product database for the KNX/EIB/TP1 module 
(753-646) must be the following version number or higher:   
Wago_TP1Klemme_753-646_2_0_367_581.vd4 

 
Pos: 12.9 /All e Seri en ( Allgemei ne Module)/Ü berschriften/Ebene 2/Sicher hei tshi nweise -  Überschrift 2 @ 6\mod_1260180299987_21.docx @ 46724 @ 2 @ 1 
 

2.3 Safety Advice (Precautions) 
Pos: 12.10 /Serie 759 ( WAGO-Software)/Hi nweise zur D okumentati on/Hinweise/Hinweis:  Aktuelle Sicherheitssoftware verwenden! + Nicht benötigte Software deakti vier en oder de.!  @ 12\mod_1333429179862_21.docx @ 92870 @  @ 1 
 

 

 

 
Use up-to-date security software! 
Secure operation of the PC system can be at risk as a result of malware such a 
viruses and Trojans, as well as related threats such as denial-of-service attacks. 
Therefore, make sure that the latest security software and definitions are always 
installed on the PC system. 

 

 

 

 
Disable or uninstall software that is no longer required! 
The vulnerability of a PC system against malware and related threats increases 
with the number of installed or active software components (applications and 
services). Therefore, uninstall or disable software components that are not needed 
for the purpose at hand. 

 
Pos: 13 /D okumentation allgemei n/Glieder ungselemente/---Seitenwechsel--- @ 3\mod_1221108045078_0.docx @ 21810 @  @ 1  
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3 ETS 
The ETS (Engineering Tool Software) was specially developed for planning, 
project design and startup of KNX/EIB networks. During its development, ETS 
functionality was optimized and the latest version includes options for setting up, 
maintaining, servicing and expanding KNX networks.  

The software integrates all the major components of a KNX network such as lines, 
devices and building areas into an intuitive, easy-to-use package that enables 
controllers and device behaviors to be set up or modified. The software programs 
and configures individual devices within the bus system in order to implement 
new requirements effectively and quickly. 

The manufacturer-independent design of ETS enables manufacturers in the 
building automation industry to integrate their devices into the ETS product 
database using certified standards. This manual describes devices developed 
WAGO Kontakttechnik GmbH & Co. KG. 

 

 

 
Additional information 
Additional information about ETS can be found on the manufacturer’s website 
http://www.knx.org. 

 

3.1 WAGO ETS Plug-ins 
The WAGO ETS Plug-ins described in this document are an extension of the ETS 
product database for using WAGO devices such as the KNX/EIB/TP1 Module 
(753-646) and the KNX IP Controller (750-889), as well as the KNXnet/IP Router 
(consisting of the KNX Module and KNX IP Controller). This extension enables 
you to configure WAGO devices via ETS. 

The software’s enhanced structure offers intuitive navigation — providing both 
new experienced ETS users with exceptional usability. 

The key feature of the KNX/EIB/TP1 Module and Controller software is the 
ability to map WAGO network variables 1:1 to communication objects in the 
ETS. 

Communication objects are activated via a checkbox in the “Edit Parameters” 
dialog. The communication object is visible in the topology area of the ETS when 
this checkbox is checked, and is hidden when the checkbox is unchecked. 

Communication objects are given the same name as the network variable they are 
mapped to. This ensures that the internal mapping of the WAGO software is also 
represented inside ETS. 

http://www.knx.org/
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3.2 Access to KNX Devices via ETS5 
ETS provides the following options in order to access KNX devices within a bus 
system: 

• USB 
• ETHERNET (“KNXnet/IP” or “KNXnet/IP Routing”) 

The ETS5-equipped PC used for project design must be connected to a KNX 
interface.  
Within ETS5, an interface can be configured via “Bus” > Connections > 
Interfaces > Configured Interfaces > [+].  

 

Figure 1: “Bus” Tab 

If the KNX IP Controller functions as a KNXnet/IP Router, you can connect it 
directly to a standard ETHERNET interface on your PC using an RJ-45 cable. 

In this case, the cable runs from ETHERNET to twisted pair and twisted pair to 
ETHERNET via the KNX IP Controller (750-889) and the KNX/EIB/TP1 
Modules (see also Section “KNXnet/IP Router Parameterization”). 

3.3 Interworking Datapoint Types (DPTs)  
DPTs describe defined formats and data widths of communication objects. 
The KNX Module supports the following EIB data widths: 
• 1 … 7 bits 
• 1 … 4 bytes 
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• 6 bytes 
• 8 bytes 
• 10 bytes 
• 14 bytes 

 

 

 
Additional information about “Interworking Datapoint Types”! 
Additional information about “Interworking Datapoint Types” can be found at 
http://www.knx.org. 

 

3.4 Syntax of Network Variable Names 
Each network variable name contains the program name. It is preceded and 
separated from the actual name by a period. 

 

 

 
“Show short name” option 
The “Show short name” option in the ETS Plug-in user interface (see Section 
“KNX/EIB/TP1 Module/KNX IP Controller” >… > “'View' menu item”) makes it 
possible to suppress the display of the program name. This also removes the 
prefix, infix (in this case, the “period” character between the basic name and the 
suffix) and suffix. The communication objects in the ETS user interface are then 
also displayed accordingly in abbreviated form! 

3.4.1 Syntax for Simple Variable 

The syntax for simple variable names is: 

 <Program name>.M<No1>_<No2>_<Basic name> 

Table 4: Syntax for Simple Variable 
Wildcard Length Explanation 
<No1> Digits KNX Module number 
<No2> 3 digits Data address 
 

3.4.2 Syntax for Array Variables 

The syntax for array variable names is: 

 <Program name>.M<No1>_<No2>_<Basic name>[<No3>] 

http://www.knx.org/
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Table 5: Syntax for Array Variable 
Wildcard Length Explanation 
<No1> Digits KNX Module number 
<No2> 3 digits Identifies variable array 
<No3> Digits Identifies variable in array 
 

3.4.3 Syntax for Nested Variables 

The syntax for names of nested variables is: 

 <Program name>.M<No1>_<No2>_<Basic name>[<No3>] 

Table 6: Syntax for Nested Variables 
Wildcard Length Explanation 
<No1> Digits KNX Module number 
<No2> 3 digits Identifies variable group 
<No3> Digits Identifies variable in group 
 

3.4.4 Syntax for Nested Array Variables 

The syntax for names of nested array variables is: 

 <Program name>.M<No1>_<No2>_<Basic name>._<No3><Suffix>[<No4>] 

Table 7: Syntax for Nested Variables 
Wildcard Length Explanation 
<No1> Digits KNX Module number 
<No2> 3 digits Identifies main group 
<No3> Digits Identifies subgroup in main group 
<No4> Digits Identifies variable in subgroup 
 

Pos: 14.2 /Dokumentation allgemei n/Glieder ungselemente/---Seitenwechsel--- @ 3\mod_1221108045078_0.docx @ 21810 @  @ 1 
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3.5 Importing the ETS-Plug-in in ETS5 
To import the ETS plug-in, select the corresponding vd4 file:  

1. Click the “Catalogs” tab in the ribbon. 

2. Click the [Import…] button.  

 

Figure 2: Importing Products  

 The “Open product file” dialog appears. 

 

Figure 3: Importing Products – Select File Path 

3. Find the file path of the product file to be imported in the directory and click 
[Open]. 

 

 

 
Multiple selections are possible. 
To import multiple products at the same time, press and hold the [SHIFT] button.  
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Figure 4: Progress Display – Analysis 

 A prompt shows you the progress of the import. The product file is 
analyzed. You are then prompted to select the product language(s): 

 

Figure 5: Selecting the Product Language 

4. Select the product language(s): 

 • Click the language(s) you want to select. To select multiple languages, 
 press and hold the [SHIFT] button. The languages selected are 
 highlighted in blue. Then click the [Import Selected Languages] 
 button.  
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 • If you want to import all available languages in the software interface, 
 click the [Import All Languages] button directly. 

 

Figure 6: Progress Display – Conversion 

 A prompt shows you the progress of the import: 
The project file is read, translation(s) loaded and the project file converted. 

 If you had selected multiple product files for import, the process is repeated 
for each product file.. 

 

Figure 7: Progress Display – Completion 
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5. A message then appears that the import has been completed successfully. 
Click [OK] to close the window. 

 The ETS product database is updated and henceforth includes imported 
products, e.g., KNX module and KNX IP controller in this example.  

 

Figure 8: Product Catalog (Extract) 

 

 

 

 
Importing e!COCKPIT .xml Files 
When using e!COCKPIT, the product database for the KNX/EIB/TP1 module 
(753-646) must be the following version number or higher:   
Wago_TP1Klemme_753-646_2_0_367_581.vd4 
 
If an older file was added, the project or database may need to be discarded to 
correctly import the current product database. 

 

3.6 Opening a Project 
1. To open a project in the ETS, select the “Overview” tab. 

 

Figure 9: Selecting a Project (Extract) 

2. Double-click the required project to view the project. 
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Figure 10: Project in the ETS – Topology View (Extract) 

 
Pos: 14.4 /Dokumentation allgemei n/Glieder ungselemente/---Seitenwechsel--- @ 3\mod_1221108045078_0.docx @ 21810 @  @ 1 
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4 KNX/EIB/TP1 Module / KNX IP Controller 
Parameterization 
The KNX/EIB/TP1 Module (753-646), referred to as the KNX Module, and the 
KNX IP Controller (750-889) use the same ETS Plug-in; however, the controller 
offers additional functions. This description applies to both the KNX Module and 
the Controller. Other functions are described. 

The following section describes the procedure for using the ETS Plug-in for the 
KNX Module and the KNX IP Controller within the ETS. The ETS Plug-in is 
contained in the product database. 

4.1 Opening the ETS Plug-in 
1. To go to the plug-in interface, select the required device in the topology 

view. 

 

Figure 11: Selecting a Device 

2. Go to the “Parameter” tab if necessary. 
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Figure 12: Opening the “Parameter” Dialog 

3. Click the [Open product specific parameter dialog] button.  
The plug-in for the selected device opens. 
 

 

Figure 13: Plug-ins Window 
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4.2 Graphical User Interface of the ETS Plug-in 
The graphical user interface displays all relevant data applicable to configuring 
the KNX Module. 

The main window is divided into various areas, which are described in the 
following sections: 

 

Figure 14: Overview of the ETS Plug-in 

Table 8: Legend for the “Overview of the ETS Plug-in” Figure 
Pos. Description/Section 

1 Main Menu 
2 Toolbar 
3 “Network Variables” tab – List of network variables 
4 “Properties” tab 
5 Status bar – Percentage bar 
6 “Network variables” tab – EIB datatypes 

 
This display structure cannot be changed, although the toolbar and the Properties 
window may be shown or hidden above the View menu item in the main menu. It 
is also possible to use the mouse to resize the individual window panes to the 
desired height and width.  

4.2.1 Main Menu 

The main menu contains the following items, each contains its own submenu 
items: 
• File 
• View 
• Tools* 
• Options 
• Help 
*only when configuring controllers 
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4.2.1.1 “File” Menu Item 

 

Figure 15: “File” Menu Item 

Table 9: “File” Menu Item 
Menu Item Description 
Import SYM-
XML file… 

Imports an SYM_XML file. 

Save Saves the settings to the database of the ETS. The basic 
changes made via the ETS Plug-in are saved in the ETS. The 
menu item is only activated if changes were made.  
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Table 9: “File” Menu Item 
Menu Item Description 
Export The following submenu items enable you to export the 

current configuration. 
XML (Backup) 
Export as XML file (not a SYM_XML file). All settings of 
WAGO devices (assignment of network variables, their 
properties, the settings of network variables and the 
assignment of communication objects to group addresses, 
etc.) are saved as an XML file. This file is used as a backup 
or as a template for the ETS Plug-in. When importing this 
file, the predefined settings are accepted in the devices and 
replace any existing settings. 
CSV (editing parameters) 
Export as CSV file. The exported ASCII text contains a table 
of the network variables visible in the ETS. The first row is 
used as the header and contains the property names. Any 
additional row corresponds to a network variable. The 
property values (table columns) are separated by semicolons. 
You can open and edit the exported *.csv file with Excel or a 
text editor. 

 

 

 
Notes on saving a *.csv file after editing! 
Excel cannot save any additional information in 
CSV format, such as cell formats, row heights or 
column widths. Therefore when saving, confirm 
the format warning prompt with “Yes” in order to 
retain the *.csv file format! 
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Table 9: “File” Menu Item 
Menu Item Description 
Import Use the following submenu items to import a configuration.  

XML (Restore) 
Import as an XML file. This is not a SYM_XML file. 
CSV 
Export as a CSV file. The imported .csv file must have been 
previously exported and, if necessary, edited with Excel or a 
text editor. This enables you to change group address 
associations and other properties of network variables. 
However, name, data type (DPT) and CO number cannot be 
changed. 

 

 

 
CSV file does not contain a fully specified 
configuration! 
Unlike an exported XML file, the CSV file does 
not contain a fully specified configuration. It is 
therefore not suitable for: 
• transferring the configuration to a different   
  device 
• reimporting after a manual change of the ETS  
  visibility of variables 
• reimporting after an XML or SYM_XML import. 

 

Print... Prints the current configuration.  
Two different documentation types can be selected: 
• “Based on group addresses” 
• “Based on network variables”. 

Print preview… Displays the print preview. The same two documentation 
types can be selected (see “Print…” menu item). 

Exit… Closes the Plug-in. If the modifications have not been saved, 
the software will provide a prompt with the option to save the 
changes. 

 
4.2.1.1.1 Exporting a Configuration as an XML File (Backup) 

1. In the main menu choose File > Export > XML (Backup).  

2. Enter a storage location in the opened dialog.  

3. Left-click [Save] to save the configuration and close the dialog. 

 

 

 
Routinely save the configurations! 
It is recommended that the configurations are regularly exported to create a 
backup file. 
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4.2.1.1.2 Exporting a Configuration as a CSV File 

 

 

 
CSV file does not contain a fully specified configuration! 
Unlike an XML file, the CSV file does not contain a fully specified configuration. 
It is therefore not suitable as a backup file. 

1. In the main menu choose File > Export > CSV. 

2. Enter a storage location in the opened dialog.  

3. Left-click [Save] to save the configuration and close the dialog. 

 

 

 
Simple editing of group address associations and other properties of network 
variables! 
You can edit the properties of network variables with Excel or a text editor. Many 
text fields start with an additional blank space in order to prevent accidental 
automatic Excel conversions. 
After editing, be sure to save the file again in *.csv file format.  

4.2.1.1.3 Import XML File (Backup Restore) 

1. In the main menu, choose File > Import > XML (Restore).  

2. Search for the required XML file in the dialog that opens.  

3. Left-click [Open] to import the configuration file and close the dialog. 

4. A warning prompt indicates that importing a configuration will overwrite all 
existing settings and assignments. If you agree, click the [Yes] button. 

 

 

 
Retain settings via the ETS Import/Export function (XML)! 
The export or import function (XML) enables you to recover previous settings 
after a new installation of the ETS, or to load them another PC. 
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4.2.1.1.4 Importing a CSV File 

 

 

 
CSV files do not contain a fully specified configuration! 
Unlike an exported XML file, the CSV file does not contain a fully specified 
configuration. It is therefore not suitable for: 
• transferring the configuration to a different device 
• reimporting after a manual change of the ETS visibility of variables 
• reimporting after an XML or SYM_XML import. 

1. In the main menu, choose File > Import > CSV. 

2. In the dialog that opens, search for the CSV file required.  

3. Left-click [Open] to import the file and close the dialog. 

4. A warning prompt indicates that importing a configuration will overwrite all 
existing settings and assignments. If you agree, click the [Yes] button. 

4.2.1.2 “View” Menu Item 

 

Figure 16: “View” Menu Item 

Table 10: “View” Menu Item 
Menu Item Description 
Show toolbar When checked, displays the toolbar. The toolbar 

is otherwise hidden. 
Show properties When checked, the “Properties” tab is displayed 

on the right in the window. It is otherwise 
hidden. 

Show short names The network variable names are displayed in 
short form, e.g., “FbDPT_Switch” instead of 
“PLC_PRG.M2_001_FbDPT_Switch”.  

 
Selecting the Show Short Name option displays the network variable names in 
abbreviated form — both in the Plug-in window, as well as with the 
communication objects in the ETS user interface. 

The short name omits the following: 
• the preceding program name, including the separator 
• the prefix for identifying the KNX Module and index of the DPT function 

block 
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• the infix (between basic name and suffix) for identification when nesting. 

Table 11: Structure of the Network Variable Name – Long/Short Form 
Langform Short form 
<Program name>.<Basic name> <Basic name> 
<Program name>.KNX<No>_<Basic name> <Basic name> 
<Program name>.M<No1>_<No2><Basic name> <Basic name> 
<Program name>.M<No1>_<No2><Basic name>[<No3>] <Basic name>[<No3>] 
<Program name>.M<No1>_<No2><Basic name>.<Suffix> <Basic name>.<Suffix> 
<Program name>.M<No1>_<No2><Basic name>. <Suffix> 
<No4>] 

<Basic 
name>.<Suffix>[<No4>] 

 
More information on the syntax of network variable names can be found in the 
Section “ETS” > … > “Syntax of Network Variable Names.” 

4.2.1.3 “Tools” Menu Item 

The Tools menu item is only displayed for controller configuration. 

  

Figure 17: “Tools” Menu Item 

Table 12: “Tools” Menu Item 
Menu Item Description 
Start CODESYS… Start the WAGO-I/O-PRO software *) 
Web browser… Start the web browser with the Web-based 

Management (WBM) **) 
*) Requirement: Correct path to the .exe file of the software, see Section “Finding the File Path to  WAGO-I/O-PRO” 
**) Requirement: Available connection to the controller. 
 

 

 

 
Configure the IP parameters prior to CODESYS or web access! 
To start CODESYS or the web browser via ETS, the IP parameters must be set 
via Options > IP Parameters… (see Section “Setting IP Parameters”). 

4.2.1.4 “Options” Menu Item 

  

Figure 18: “Options” Menu Item – Controller Example 
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Table 13: “Options” Menu Item 
Menu Item Description 
IP parameters… *) This opens the “IP Controller” dialog to set the IP 

parameters for the controller. *) 
Options… This opens the “Options” dialog to enter settings 

for functions such as telegram delay and automatic 
save. 

*) only when configuring controllers 
 
The Options… menu item opens the “Options” dialog. 
 
The “Options” dialog consists of 3 tabs: 
• Parameters 
• CODESYS 
• Autosave 
 

4.2.1.4.1 Defining the Telegram Delay After Reset 

Use the “Parameters” tab to define the telegram delay after a reset.  

This is the smallest interval that must be observed between successive telegrams. 
0, 50, 100, 250 and 500 milliseconds [ms] can be selected. 

 

Figure 19: “Options” Dialog – “Parameters” Tab 

4.2.1.4.2 Finding the File Path to WAGO-I/O-PRO 

In the “CODESYS” tab, enter the file path of the .exe file for the WAGO-I/O-
PRO (CODESYS) software. 
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Figure 20: “Options” Dialog – “CODESYS” Tab 

4.2.1.4.3 Setting the Autosave Function 

Use the “Autosave” tab to define automatic save for the current configuration. For 
this, the Enable automatic save of the configuration checkbox must be checked. 
Enter a number that defines the save interval in minutes.  

 

 

 
“Autosave” function saves changes in the database! 
The “Autosave” function is identical to the normal “Save” function and saves 
changes in the ETS database. 
An XML file is not saved (as is the case with File > Export > XML (Backup)). 

 

Figure 21: “Options” Dialog – “Autosave” Tab 
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4.2.1.4.4 Setting IP Parameters  

The IP Parameters… menu item is only displayed when configuring the 
controller. This opens the “IP Controller” dialog: 

 

Figure 22: “IP Controller” Dialog – KNXnet/IP Parameters of the KNX IP Controller 

The KNX IP Controller needs an IP address for network integration. Various 
options for assigning the IP address include “manual,” “BootP,” “DHCP.” 

Use the [Scan IP] button to search the network for the IP address of the controller 
specified by the MAC address. If no suitable device is found for the MAC 
address, the device is marked accordingly. An automatic search is also performed 
for the device after opening the parameters dialog. 

 

 

 
Specify the MAC address in the IP parameters dialog! 
The MAC address of the KNX IP Controller must be specified in the MAC 
address field. The address is located on the back of the controller and on a self-
adhesive, tear-off label on the side of the controller. 

4.2.1.5 “Help” Menu Item 

 

Figure 23: “Help” Menu Item 
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Table 14: “Help” Menu Item 
Menu Item Description 
About… Displays information about the ETS Plug-in. 
 

4.2.2 Toolbar 

The toolbar provides fast and convenient access to frequently used functions of 
the main menu. 

 

Figure 24: Toolbar 

Table 15: Toolbar 
Button Action 

 Imports an SYM_XML file, similar to selection of the SYM_XML 
file. 

 Saves the settings to the ETS. The SYM_XML file is not changed. 

 Prints the current configuration. 

 
Shows or hides the “Properties” tab. 

 Opens the “Options” dialog. 

 Opens the “IP Parameters” dialog. *) 

 Exports the current configuration as an XML file (not a 
SYM_XML file). 

 Imports a configuration as an XML file (not a SYM_XML file). 
*) only when configuring controllers 
 

4.2.3 “Network Variables” Tab – List of Network Variables 

A “List of network variables” is located in the middle of the “Network Variables” 
tab. This lists all the network variables available that you can associate with group 
addresses from the ETS. These network variables each have a specific data point 
type by which they can be filtered (see Section “'Network Variables' Tab – 
Datatypes”).  
 

 

 

 
Observe naming conventions of network variables! 
Observe the syntax conventions for network variable names, which are described 
in detail in the Section “ETS” > … > “Syntax of Network Variable Names.” 

The following properties are listed in the “List of Network Variables” table: 
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Table 16: List of Network Variables  
Table Column Value Description 
  /  Checkbox for enabling or disabling 

visibility in the ETS. 
No. (Table row number) Consecutive number of the table rows. 
CO # (Communication 

object number) 
Communication object number in the ETS' 
topology. The communication object 
number is assigned automatically. 

Name (Network variable 
name) 

The network variable name is taken from 
WAGO-I/O-PRO (CODESYS) and is 
preceded by the “program name.” With 
the appropriate setting in the “View” menu 
item, only the short name is shown; the 
display of the program name is disabled. 

Type (Data point type 
name or, if without 
type, amount + unit 

of data width)  

Data point type name. If the data point has 
no type, its data width is shown. 

Send on reset  On/Off If the controller is reset, this variable 
automatically sends the current value on 
the bus or not. 
This function can be used to initialize the 
specific group object. 

Read on reset  On/Off If the controller is reset, this variable 
automatically reads the current value from 
the bus or not. 
This function can be used to initialize the 
associated function block. 

Timeout (amount + unit) The data point has a watchdog and expects 
an update within the specified time. 

Cyclic send (amount + unit) Time interval for repetitive cyclic send 
operation. 

Group 
addresses 

(x/x/x) Assigned KNX group addresses.  
A data point can be associated with 
several group addresses, maximum 253 
group addresses/assignments. Data points 
and group addresses are associated in the 
topology window of the ETS. 

 
Checkbox for Visibility in the ETS 
The checkbox at the beginning of the line for each list entry defines whether the 
corresponding network variable in the ETS is visible as a communication object 
and appears in the topology list. 
Some of the current properties/values of the network variables, e.g., “Read on 
reset,” can be edited in the area of the “Properties” tab (see Section “'Properties' 
Tab”). 
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Multiple selection is supported! 
In order to change the properties of several network variables at the same time, 
you can mark several lines in the “List of network variables” simultaneously. The 
changes that you make in the “Properties” tab then apply to all network variables 
marked in the list. 

 
4.2.4 “Network Variables” Tab – EIB Datatypes 

The “Network Variables” tab contains the “EIB datatypes” in the left-hand area of 
the user interface. The tree structure displayed enables you to filter the “List of 
network variables” by EIB datawidth, EIB datatypes or EIS types.  

The EIB and EIS types represent the available data point types in the ETS. The 
“List of network variables” only shows those network variables that correspond to 
the data type you have selected. 

The “EIB datawidths” tree node enables you to filter the network variables 
independently by datawidth rather than the actual data type. This enables you to 
also list the new datawidths without a type. 

 

Figure 25: Selection of EIB Datatype 9 xxx, Corresponds to DPT_Value_Temp 
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Figure 26: Selection of EIS Type EIS 5, Corresponds to DPT_Value_Temp 

 

Figure 27: Selection of EIB Datawidth 2 Byte, also Contains DPT_Value_Temp 

 

 

 
Only one attribute (data type/datawidth) can be used as a filter! 
Only one attribute can be entered as a filter.  
Multiple selection in the EIB datatype window is not possible. 
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4.2.5 “Properties” Tab 

 

Figure 28: “Properties” Tab 

The “Properties” tab displays the properties of selected network variables. You 
can read or write properties here. The settings made are immediately updated in 
the “List of Network Variables” table. 
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Table 17: Properties of Network Variables 
Designation Explanation Read / Write 
Name Description of the selected network 

variable. If several network variables are 
selected: empty 

R 

Startup behavior 
Send on reset 
checkbox 

If the checkbox is checked, values are 
updated after a device reset. The values 
are updated with a voltage reset, the reset 
of the node from the ETS and a software 
reset of the IEC application. 

RW 

Read on reset 
checkbox 

If the checkbox is checked, the device 
reads the current value from the bus after 
a device reset. 

RW 

Timing behavior 
Timebase Conversion of the timebase to seconds 

[sec.] or minutes [min.]. Only enabled if 
the Cyclic send or  Timeout checkbox is 
selected 

R/RW 

Cyclic send 
checkbox 

If the checkbox is checked, the device 
sends its value to the bus with the 
defined interval.  

R/RW 

Timeout  
checkbox 

If the checkbox is checked and the 
telegram is not updated within the 
specified time, the device indicates a 
timeout on the corresponding FbDPT 
function block in the PLC. The data 
point has a watchdog and expects a 
program update within the specified 
time. 

R/RW 

 
If you have made multiple selections in the “List of network variables,” the 
properties of all selected network variables can be updated simultaneously. 
Checkboxes in which the selected network variables are different are marked in 
blue (see figure “Multiple Selection for Editing Network Variables”). 
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Figure 29: Multiple Selection for Editing Network Variables 

4.2.6 Status Bar  

The “Assigned group addresses” percentage bar is shown on the right of the status 
bar. This indicates the relative usage of the ETS Plug-in based on the following 
limits: 

• 253 communication objects for the configuration of controller and modules 
• 254 group addresses for the configuration of controller and modules 
• 254 associations for the configuration of controller and modules. 

Usage is stated as a percentage of the specified capacity. It is displayed as a green 
bar. 

 

Figure 30: “Assigned Group Addresses” Percentage Bar (Example) 

Example: 

The system is at full capacity when there are 253 communication objects or 254 
group addresses or 254 associations present. 

If two communication objects with 127 group addresses each are connected, this 
makes 254 associations. The system is then at full capacity. 

No further assignments are possible with 100 % rate of usage. 
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4.3 Importing a Symbol File in the ETS Plug-in 
Specific configurations are required to operate the KNX Module and the KNX IP 
Controller. The WAGO-I/O-PRO software generates these configurations and 
exports them to an “SYM_XML” icon file. 

In the Plug-in window:  

1. Click [File] in the main menu of the plug-in user interface. 

2. Select the Import SYM-XML file… menu item. 

 

Figure 31: “Import SYM-XML File…” Menu Item 

3. In the “Select SYM-XML file for this device” window, select a SYM_XML 
file containing the specific configuration of the KNX Module or KNX IP 
Controller. 

 

Figure 32: “Select SYM-XML File for this Device” Dialog  

A checkbox is provided below the entry field for the source file.  

• If the box is unchecked, the device configuration is overwritten with the 
data in the SYM_XML file. 
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• If it is checked, the current device configuration is synchronized with the 
settings specified in the SYM_XML file.  

If a node contains several KNX Modules, the DPTs of all bus modules are 
contained in the SYM_XML file. In this case, proceed as follows: 

4. In the Module index selection field (“Settings” area), select the KNX 
Module number for the DPTs to be imported. 

5. Click [Update] to start the synchronization. 

 

 

 
Observe the index counting method and designation! 
If a second KNX Module of this type is used on a KNX IP Controller (750-889), 
it will operate in device mode. The first KNX Module is automatically set to 
router mode. Although the first KNX Module cannot be accessed via the IEC 
application, the second KNX Module is addressed via index 2 (see also the 
manual of the KNX IP 750-889 Controller).  
The selected module index influences the naming of the network variables (see 
Section “Network Variables”). 

 

 

 
Configure KNX Modules individually! 
Several KNX Modules cannot be configured at the same time. 
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4.4 Associating Network Variables and Group 
Addresses 
The basic task of the ETS software is visualizing the associations of network 
variables of the KNX Module or KNX IP Controller with group addresses in the 
ETS and enabling them to be edited.  

4.4.1 Creating Associations 

Associations between communication objects and group addresses are created 
using “drag & drop” in the ETS.  

1. Click and hold on the required network variable from the Topology view 
and drag it to the required group address in the Group Addresses view.  

 

Figure 33: Creating an Association Using “Drag & Drop” 

Invalid association attempts are detected and indicated. 

 

 

 
Associated network variable sets the type for further associations! 
If a group address is associated with a network variable, only additional variables 
of the same type can be associated with the relevant group address. 

Alternatively, you can also create the association via the context menu of the 
relevant communication object: 

1. Right-click the communication object to open the context menu.  

2. In the context menu, select Link with…. 
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Figure 34: Object Context Menu 

The “Link With Group Address” dialog opens: 

 

Figure 35: “Link With Group Address” Dialog 

3. To go to a list with available group addresses, click the […] button. 



WAGO-Software KNX/EIB/TP1 Module / KNX IP Controller Parameterization 43 
  WAGO ETS Plug-in   

Manual  
Version 3.0.1   

 

Figure 36: Drop-down List with Group Addresses 

4. Select a target group address and click [OK] to confirm. The connection is 
established and the drop-down list is closed. 

5. Alternatively, you can create a new group address under the “New” tab 
directly that is immediately associated with the network variable. Click 
[OK] to confirm. 

The syntax of the address entered is monitored. If you make an invalid entry, the 
input field is outlined in red and no [OK] button appears: 
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Figure 37: Example of Signaling an Incorrect Entry 

6. When you have entered a correct group address (x/x/x) and name (free form 
text), the [OK] button appears. Clicking the button confirms the group 
address you created and the window closes: 

 

Figure 38: “New” Tab 

4.4.2 Deleting Associations 

1. To remove a network variable/group address association, click an object in 
the Group Addresses view. A context menu appears.  
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Figure 39: Object Context Menu 

2. Clicking the Unlink menu item removes the connection between the 
communications object and the group address. 
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5 Parameterization of the KNXnet/IP-Router in 
ETS5 
The first KNX Module behind a KNX IP Controller (and possibly behind other 
non-KNX Modules) extends the function of the KNX IP Controller to a 
KNXnet/IP Router. Any subsequent KNX modules operate in device mode. The 
KNXnet/IP Router routes telegrams from IP to a twisted-pair cable and vice versa.  

The following section describes the steps for using the KNXnet/IP router within 
the ETS.  

5.1 “IP-Router” Dialog 
Proceed as follows to parameterize the KNXnet/IP Router:  

1. Select the IP router in the ETS Topology view.  

 

Figure 40: Selecting the IP-Router 

2. Switch from the “Group Objects” tab to the “Parameter” tab to display 
the device settings.  

3. Click [+] before Device Settings to expand the submenu points. 

 • Extended Settings 
 • IP -> TP 
 • TP -> IP 
 



WAGO-Software Parameterization of the KNXnet/IP-Router in ETS5 47 
  WAGO ETS Plug-in   

Manual  
Version 3.0.1   

 

Figure 41: “Parameter” Tab 
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5.2 Operation 
The software has the basic task of setting up the KNXnet/IP Router and adapting 
its IP parameters to the network. 

5.2.1 Extended Settings 

You can view and set general data such as the device name, project number and 
installation number in the Extended Settings menu item. 

 

Figure 42: Extended Settings 

Table 18: “Extended  Settings” Menu Item of the KNXnet/IP Router 
Parameter Description 
Device name Freely selectable device name with a maximum of 30 

characters to identify the device in the ETS. 
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Table 18: “Extended  Settings” Menu Item of the KNXnet/IP Router 
Parameter Description 
Voltage monitor Response of the device to a bus power failure:  

“locked”:  Power failure and restoration are not  
  reported. 
“unlocked”:  Failure and restoration of power on the 
  bus line are reported by KNXnet/IP  
  (default).  

Routing multicast 
address 

IP address for KNXnet/IP routing: 
address reserved for KNXnet/IP: 224.0.23.12 
general address: 239.0.0.0 … 239.255.255.255 
valid address range: 224.0.0.0.0…239.255.255.255 

Project number *) Setting the Project number  
(value range 0 … 4096)  

Installation number *) Setting the installation number  
(value range 0 … 15) 

*) These settings are only required if the project contains more than one router 

 

 

 
Bus power failure and return are reported via KNX! 
If a power failure is detected on the bus line, the error is output as a KNXnet/IP 
telegram. Power restoration is also indicated via KNXnet/IP. 
Exception: Bus power failure and return are not reported if you select the 
“locked” option for Voltage monitor.  

 

 

 
Ensure uniqueness of physical addresses! 
The physical address (tunneling address) is not managed by the ETS. For this 
reason, the ETS cannot prevent a double assignment of the same physical address 
and it is recommended that an address in the upper value range is used (e.g., 
1.1.254). 

 

 

 
Assign value “0” to project and installation numbers! 
The project and installation numbers are used for the compatibility of future ETS 
developments and should have the value “0” for current ETS projects. 

 

 

 
Watch for different project numbers! 
The project number in the “Extended Device Parameters” dialog is not identical to 
the project number assigned in the ETS. 
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Incorrect entries will not be saved! 
Incorrect entries are not saved in the system! 

 

 

 
IP Parameter Settings 
The controller plug-in can be used to set the IP parameters from the ETS (IP 
Addr., Subnet, etc.), see section “KNX/EIB/TP1 Module / Controller KNX IP 
Parameterization” > … > “Setting IP Parameters”! 

5.2.2 IP -> TP 

In the IP -> TP menu item, set the parameters for filtering and confirmation of 
telegrams transmitted from the IP medium to twisted pair (TP). 

 

Figure 43: IP -> TP 

5.2.2.1 Individual Addressed and Broadcast Telegrams 

In this selection box, you set the filtering of physically addressed and broadcast 
telegrams: 

• route:   All telegrams are routed. 
• lock:   No telegram is routed. 
• filter (normal):  Filtering is performed according to the filter table. 

5.2.2.2 Group Telegrams of Main Groups 0 to 13 

In this selection box, you set the filtering of telegrams for the main groups 0 to 13: 

• route:   All telegrams are routed. 
• lock:   No telegram is routed. 
• filter (normal):  Filtering is performed according to the filter table. 
 

5.2.2.3 Group Telegrams of Main Groups 14 to 31 

In this selection box, you set the filtering of telegrams for the main groups 14 to 
31: 

• route (normal):  All telegrams are routed. 
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• lock:   No telegram is routed. 
• filter:  Filtering is performed according to the filter table. 

5.2.3 TP -> IP 

In the IP -> TP menu item, set the parameters for filtering and confirmation of 
telegrams transmitted from the twisted pair (TP) to the IP medium 

 

Figure 44: TP -> IP 

5.2.3.1 Acknowledge of Group Oriented Telegrams 

This selection box sets how telegrams for group-oriented telegrams are confirmed: 

• all:            All telegrams are confirmed. 
• only when routed: All routed telegrams are confirmed. 

5.2.3.2 Individual Addressed and Broadcast Telegrams 

This selection box sets filtering for the physically addressed telegrams and 
broadcast telegrams: 

• route:   All telegrams are routed. 
• lock:   No telegram is routed. 
• filter (normal):  Filtering is performed according to the filter table. 

5.2.3.3 Group Telegrams of Main Groups 0 to 13 

In this selection box, you set the filtering of telegrams for the main groups 0 to 13: 

• route:   All telegrams are routed. 
• lock:   No telegram is routed. 
• filter (normal):  Filtering is performed according to the filter table. 
 

5.2.3.4 Group Telegrams of Main Groups 14 to 31 

In this selection box, you set the filtering of telegrams for the main groups 14 to 
31: 

• route (normal):  All telegrams are routed. 
• lock:   No telegram is routed. 
• filter:  Filtering is performed according to the filter table. 
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6 Uninstalling the ETS Plug-in 
Proceed as follows to remove the software from your system. 

For controller:  

1. On your PC, open the Control Panel and click “Programs,” [Uninstall a 
program]. The entry “Wago-IEC61131Controller-IpRouter” is shown in 
the software list.  

2. Right-click the required entry and choose [Uninstall] in the context menu.  

For modules: 

1. On your PC, open the Control Panel and click “Programs,” [Uninstall a 
program]. The entry “Wago-TP1Clamp” is shown in the software list. 

2. Right-click the required entry and choose [Uninstall] in the context menu. 
=== Ende der Liste für Textmar ke Inhalt_mitte ===  
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